You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

32 lines
828 B

# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
{ config, lib, pkgs, ... }:
{
imports =
[ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
];
boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
boot.kernelModules = [ "fbcon" "kvm_intel" ]; # kvm_intel is disabled on the t440s
boot.extraModulePackages = [ ];
fileSystems."/" =
{ device = "/dev/mapper/vg-root";
fsType = "ext4";
};
fileSystems."/boot" =
{
mountPoint = "/boot";
device = "/dev/sda2";
fsType = "vfat";
};
swapDevices =
[ { device = "/dev/mapper/vg-swap"; }
];
nix.maxJobs = 8;
}